MikroTik SNTP-Client 2 (новый)

16 сентября 2020

Настройка точного времени, даты в микротик, скрипт полностью проверяет на российских NTP.

/system clock
set time-zone-name=Europe/Moscow

Включаем и присваиваем NTP сервера, это не важно если они окажутся не рабочими. скрипт все ровно их заменит на действующие.

/system ntp client
set enabled=yes primary-ntp=0.0.0.0 secondary-ntp=0.0.0.0

в скрипте выделены 2 NTP сервера 0.ru.pool.ntp.org и 1.ru.pool.ntp.org их можно заменить на другие, какие хотите, интервал 10 мин.

Если есть желание вводить скрипт в окне WinBox , непосредственно в планировщике (Scheduler), ниже приложен скрипт основного кода.

/system ntp client set primary-ntp=[:resolve "0.ru.pool.ntp.org"];
/system ntp client set secondary-ntp=[:resolve "1.ru.pool.ntp.org"];
/ip f a remove [find comment=ntp];
:local "pntp" [system ntp client get primary-ntp];
:local "sntp" [system ntp client get secondary-ntp];
/ip f a a list=ntp address=$pntp comment=ntp;
/ip f a a list=ntp address=$sntp comment=ntp




Скрипт написан для ввода с терминала.



/system scheduler
add interval=10m30s name="SNTP-Client 2" on-event="/system ntp client set prim\ ary-ntp=[:resolve \"0.ru.pool.ntp.org\"];\r\ \n/system ntp client set secondary-ntp=[:resolve \"1.ru.pool.ntp.org\"];\r\ \n/ip f a remove [find comment=ntp];\r\ \n:local \"pntp\" [system ntp client get primary-ntp];\r\ \n:local \"sntp\" [system ntp client get secondary-ntp];\r\ \n/ip f a a list=ntp address=\$pntp comment=ntp;\r\ \n/ip f a a list=ntp address=\$sntp comment=ntp" policy=\ ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \ start-time=startup